Enhanced Vine Registration Degraded
Incident Report for Equifax Workforce Solutions
Resolved
This incident has been resolved.
Posted Oct 14, 2020 - 23:11 EDT
Investigating
We are currently investigating this issue.
Posted Oct 14, 2020 - 21:21 EDT
This incident affected: Victim Services - Enhanced VINE (Enhanced VINELink, Enhanced VINEWatch, Enhanced VINE RegistrationLink).