Due to maintenance on 7/17/24 - Access to portal was delayed or not accessable. This has been reverted back.
Incident Report for Equifax Workforce Solutions
Resolved
This has been resolved.
Posted Jul 17, 2024 - 10:00 EDT
Update
We are continuing to investigate this issue.
Posted Jul 17, 2024 - 09:58 EDT
Investigating
Good Morning,

A new version of the Retail Portal was released during the maintenance window this morning; however, due to login issues because of database optimization, it was decided to revert back. The legacy portal is now back up and running. Login information is not impacted and all issues are resolved.
Posted Jul 17, 2024 - 09:56 EDT
This incident affected: MethCheck.