MethCheck is experiencing an issue at this time for webservice customers.

Incident Report for Equifax Workforce Solutions

Resolved

This incident has been resolved.
Posted Dec 02, 2025 - 13:54 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 02, 2025 - 13:48 EST

Update

We are continuing to investigate this issue.
Posted Dec 02, 2025 - 13:08 EST

Investigating

MethCheck is experiencing an issue at this time for webservice customers. We are actively troubleshooting the issue and will provide an update in the next 60 mins.
Posted Dec 02, 2025 - 12:13 EST
This incident affected: MethCheck.