Innovative Data Solutions Service Disruption
Incident Report for Appriss Insights Product
Resolved
This incident has been resolved.
Posted Jul 23, 2021 - 00:28 EDT
Update
We are continuing to investigate this issue.
Posted Jul 22, 2021 - 23:37 EDT
Investigating
We are currently investigating this issue.
Posted Jul 22, 2021 - 23:21 EDT
This incident affected: Data Products - Innovative Data Solutions (Assured Tenant, Assured Tenant Alias, NCIS, NCIS Alias, NCIS Statewide, FACT).